dbw - dirtbikeworld.net Members Forums

Go Back   dbw - dirtbikeworld.net Members Forums > Manufacturers > Husaberg Forum

Husaberg Forum For people that like their KTM motor bent over!

Reply
 
Thread Tools Display Modes
  #11  
Old 11-04-2018
shawbagga's Avatar
shawbagga shawbagga is offline
dbw Pro Legend
 
Join Date: Mar 2012
Location: Eaton, WA
Posts: 1,772
Apparently it starts running rough before it dies. If keep revs up high it survives but if it stalls won't restart until it cools! Sounds like coil/ignition breaking down yeah?
__________________
Lectronified '10 WR300 & '13 WR125 dingers
Reply With Quote
  #12  
Old 11-04-2018
bkerr85 bkerr85 is offline
DBW Dweller
 
Join Date: Aug 2016
Posts: 1
Maybe valve clearances


Sent from my iPhone using Tapatalk
Reply With Quote
  #13  
Old 12-04-2018
Oldscool's Avatar
Oldscool Oldscool is offline
DBW Clubman
 
Join Date: Apr 2014
Location: Adelaide
Posts: 827
Might pay to check if it has/hasn't got spark when it won't restart. At least then you'll know which area to start looking (ie. ign, fuel, mechanical).
__________________
Im just an athlete trapped in a fat body.
Reply With Quote
  #14  
Old 12-04-2018
RMJay84's Avatar
RMJay84 RMJay84 is offline
dbw Pro Champion
 
Join Date: Feb 2006
Location: Australia
Posts: 4,918
Sounds a bit like what happened to my 525EXC when the stator died, although it started off subble at high revs, and gradually become less inclined to rev until it would not run at all.

It still had spark, it just had a very weak spark.

I had the original stator rewound for $75, problem solved.

If it doesn't solve your mate's drama, at least he'll know he's go a good stator.

Otherwise could it be fueling? getting lean when hot? (stab in the dark), some sensor not working? thematic-valve not opening causing motor to heat up too much?
__________________
It pumps one way and then it pumps the other...
you have to know what you're doing with these machines and wear gloves
Reply With Quote
  #15  
Old 13-04-2018
shawbagga's Avatar
shawbagga shawbagga is offline
dbw Pro Legend
 
Join Date: Mar 2012
Location: Eaton, WA
Posts: 1,772
I can't see it being valve clearances or fuelling TBH. Valves normally issues with cold starting & it's been running fine for years so can't imagine fuelling has changed. He's done the stator & Thermo fan & ran well yday so wait & see I guess. Stator safe bet I reckon
__________________
Lectronified '10 WR300 & '13 WR125 dingers
Reply With Quote
  #16  
Old 2 Days Ago
vss304's Avatar
vss304 vss304 is offline
dbw Pro
 
Join Date: Feb 2011
Location: Wagin WA
Posts: 205
Quote:
Originally Posted by Pete40 View Post
That's the fuel pump issue. Is he sure it was replaced with updated fuel pump under warranty? I got one done even out of warranty.
You had a better experience than me then. I bought mine from a Husaberg dealer and when the fuel pump died I called to inquire about warranty and was told that it was a problem they had never heard of but they would love to sell me a replacement for $500.

Don't deal with them anymore. Aftermarket replacement cost $90 and she's been perfect since.
__________________
2010 Berg FE450
1984 IT200
1989 KX250

1990 DT175


Quote:
Originally Posted by Battered Sav View Post
Doesn't matter how smart, right or 'enlightening' the message is, if it's delivered in a shit stained envelope nobody is going to read/heed it.
Reply With Quote
  #17  
Old 2 Days Ago
shawbagga's Avatar
shawbagga shawbagga is offline
dbw Pro Legend
 
Join Date: Mar 2012
Location: Eaton, WA
Posts: 1,772
Just to close out this thread(hopefully for his sake) it was the stator it would seem. No issues since putting it in. Put a rad fan in too
__________________
Lectronified '10 WR300 & '13 WR125 dingers
Reply With Quote
  #18  
Old 2 Days Ago
choppiektm's Avatar
choppiektm choppiektm is online now
dbw Factory Pro
 
Join Date: Aug 2007
Location: wingham
Posts: 880
Quote:
Originally Posted by shawbagga View Post
Just to close out this thread(hopefully for his sake) it was the stator it would seem. No issues since putting it in. Put a rad fan in too
Thanks for letting us know
__________________
2008 530
15 rmz450 sons
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Diagnosis Dying Bike Interloper GasGas Forum 5 01-02-2015 09:59 PM
Is the 450 a dying breed? MKB KTM Forum 49 04-09-2012 08:33 PM
2T Keeps Dying Scottydee General Bike Related Discussion 17 07-08-2012 04:12 PM
How to tell if your Reg/Rec is dying? crusier Honda Forum 0 19-02-2010 07:39 PM
'06 CRF dying on/after closed throttle when hot disco Honda Forum 42 07-03-2006 09:00 PM


All times are GMT +11. The time now is 08:04 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.