dbw - dirtbikeworld.net Members Forums

Go Back   dbw - dirtbikeworld.net Members Forums > Manufacturers > Sherco Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 08-07-2017
ShercoWoolly ShercoWoolly is offline
DBW Dweller
 
Join Date: Jul 2017
Posts: 2
Question No spark on Sherco se510i

Hi guys

Hoping someone can help me out. After a ride or a good warm up on my 2012 sherco 510 and letting it cool down for half an hour. I have no spark!! If I leave it cool completely it will fire up again. It will fire up cold and hot but not after a good run and cool down. I'm thinking a sensor but could be wrong. Strange how it is fine when cold or hot but not cool. If that makes sense. Perhaps a failing coil?

Please if anyone has seen their problem or can recommend a possible solution. Please let me know.

Cheers
Reply With Quote
  #2  
Old 10-07-2017
arrow's Avatar
arrow arrow is online now
dbw Pro Champion
 
Join Date: Apr 2003
Location: Pilbara WA
Posts: 4,756
can be hard to diognose those ones but I would take a stab in the dark at your stator or ignition coil.

But there is no easy way start with the basics, kill switch and your wiering harness to make sure they are ok, no wires rubbed through or chaffing.
Get the specs for your electrical system and check your resistance and continuity readings cold for a base line reading and then run the bike until it stops then quickly test your components again and compare.
Reply With Quote
  #3  
Old 23-08-2017
ShercoWoolly ShercoWoolly is offline
DBW Dweller
 
Join Date: Jul 2017
Posts: 2
Thanks mate. You were spot on. Ignition pickup is the problem. Having trouble sourcing one in Australia without having to buy the stator with it. Any ideas on where I can get one?


Sent from my iPhone using Tapatalk
Reply With Quote
  #4  
Old 23-08-2017
arrow's Avatar
arrow arrow is online now
dbw Pro Champion
 
Join Date: Apr 2003
Location: Pilbara WA
Posts: 4,756
call Small Coil Rewinds in Geelong Victoria, send it down to them and they will have a new pickup coil and test your stator etc and fix it
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sherco 2015 300 SEF-R, 300 SE-R and 450 SEF-R impressions & review - Sherco Ride Day mr bergman Sherco Forum 20 17-08-2015 02:02 PM
No Spark? shanematt Tech Talk 6 05-12-2007 10:59 AM
TTR 600 , no spark . jasern Yamaha Forum 5 03-10-2006 08:07 PM
To spark or not to spark? Semie Tech Talk 9 20-08-2006 12:14 PM
no spark Vertex Tech Talk 14 11-01-2004 01:19 PM


All times are GMT +11. The time now is 12:03 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.