dbw - dirtbikeworld.net Members Forums

Go Back   dbw - dirtbikeworld.net Members Forums > The Workshop > Tech Talk

Tech Talk Proudly Sponsored by Mainjet Motorcycles

Reply
 
Thread Tools Display Modes
  #1  
Old 10-01-2012
Spac's Avatar
Spac Spac is online now
dbw Pro Addict
 
Join Date: Jun 2005
Location: A bit out of Canberra.
Posts: 8,543
TTR50 electrical drama.

This is f$%king with my head...

Bike has no spark when you crank it on the starter, but fires into life easily when you push-start it.
Like me, you probably just thought "Crook battery not supplying enough grunt to turn the starter and run the CDI/coil at the same time", but its more than that.

I've tried:
1. Use a seperate car battery to supply +12V power the CDI, and the bike's battery to crank the motor. No spark.

2. Use the car battery to drive the starter motor, and the bike battery to run the bike's electrics. No spark.

3. Using the car battery to drive the starter and power the CDI (ie: Only use the ignition trigger from the stator). No spark.


Needless to say, the car battery has tons of grunt to drive the starter motor - it turns over at a good speed, but there's still no spark.
When you push it around in gear, it keeps supplying a solid spark even when you're walking slowly and its in 3rd gear (ie: the engine revs are very low).

Basically, even when the starter motor & starter circuit is electrically isolated from the bike, it seems to 'know' the difference between being push started and the starter motor...

WTF is going on!? x100.

Other stuff that may be relevant/interesting:
*Bike is E-start only.
*12V system.
*One wire to the coil (typical Yamaha coil).
*New battery (the owner replaced the battery shortly after this problem first appeared, reasonably thinking it was simply a dead battery).
*Charges at 13.7V when running.
*Runs great when it's running.
*Runs happily with battery disconnected.
*I've been right over the wiring loom (inc removing it from the bike), and can see no sign of any sort of damage, corrosion or anything ugly.
*Neutral cut-out switch is working fine.
*Starter motor spins the correct way (yes, I've started looking for the crazy things).

I've drawn up a wiring diagram for it (couldn't find one already on line), which I'll post up after I work out how to get it off my phone and onto the PC.

__________________
Everything from an XL175 to a Beta 300 to a Hodaka Wombt to a KX500.
They're all fun.
Reply With Quote
  #2  
Old 10-01-2012
JB's Avatar
JB JB is offline
dbw Pro Legend
 
Join Date: Jun 2009
Location: Sth of Brissy
Posts: 1,406
I had the same sort of drama with our PW80,I know they are completly different bikes but it ended up being the coil.,it was proper stuffed.
__________________
Reply With Quote
  #3  
Old 11-01-2012
Spac's Avatar
Spac Spac is online now
dbw Pro Addict
 
Join Date: Jun 2005
Location: A bit out of Canberra.
Posts: 8,543
And here it is: Wiring Diagram for a Yamaha TTR50 TTR50E - my contribution to society.

The unmarked rectangular component below the regulator is the thermal switch, which drives a 15W heating element in the carburetor. I can only assume its for seriously cold conditions.

I also forgot to include the black earth wire off the CDI box.



Direct link, so you can zoom in:
http://s46.photobucket.com/albums/f1...ingDiagram.jpg

None of which is helping me get this bloody thing fixed.
__________________
Everything from an XL175 to a Beta 300 to a Hodaka Wombt to a KX500.
They're all fun.
Reply With Quote
  #4  
Old 11-01-2012
Spac's Avatar
Spac Spac is online now
dbw Pro Addict
 
Join Date: Jun 2005
Location: A bit out of Canberra.
Posts: 8,543
I traced all of the wiring out. Even had the main loom entirely out of the bike and partially unwrapped. I see it in my sleep.

__________________
Everything from an XL175 to a Beta 300 to a Hodaka Wombt to a KX500.
They're all fun.
Reply With Quote
  #5  
Old 12-01-2012
Rumbleguts's Avatar
Rumbleguts Rumbleguts is offline
dbw Pro Legend
 
Join Date: Jul 2007
Location: Stuck inside of Mobile with the Memphis blues again
Posts: 1,850
oops, sorry, deleted my last post. (I had second thoughts about it)
__________________
XR400 03

Sponsored by Heinz Baked Beans
Past rides - 1976 XL175
Reply With Quote
  #6  
Old 12-01-2012
MrGenius MrGenius is offline
dbw Factory Pro
 
Join Date: Sep 2005
Location: Sydney
Posts: 701
Ignition switch working Nath?
Im sure youve already tried but unplug the ign switch and then power the starter from battery.
My mates sons one [although has kickstart also] wouldnt start off the button but once the ign unplugged starts off the kicker or starter with external power source.
__________________
Genius by name, rarely by nature
Wetblasting Alloy Parts - PM for details
Reply With Quote
  #7  
Old 12-01-2012
Rumbleguts's Avatar
Rumbleguts Rumbleguts is offline
dbw Pro Legend
 
Join Date: Jul 2007
Location: Stuck inside of Mobile with the Memphis blues again
Posts: 1,850
I think it could only be the CDI unit that may be causing your problem going by what you have tried already.
__________________
XR400 03

Sponsored by Heinz Baked Beans
Past rides - 1976 XL175
Reply With Quote
  #8  
Old 12-01-2012
Spac's Avatar
Spac Spac is online now
dbw Pro Addict
 
Join Date: Jun 2005
Location: A bit out of Canberra.
Posts: 8,543
Yeah... Its got me stuffed... I think I'm at the point where I need to start swapping bits until I find where the problem is.

Took the stator cover off this morning. I was vaguely wondering if there might have been something like a loose flywheel that was moving away from the stator pick-up when being spun by the starter motor, but no sign of anything wrong under there.

Also disconnected the carb heater, just in case it was stuck on and causing a voltage drop, but no dice.
__________________
Everything from an XL175 to a Beta 300 to a Hodaka Wombt to a KX500.
They're all fun.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
jump from pw50 to ttr50 converge General Bike Related Discussion 10 08-11-2011 03:38 PM
Mature aged Electrical Apprentinceship brownie82 Off Track Talk 26 06-04-2011 08:21 PM
Sherco Electrical drawings andrewktm450 TM, Ossa, Aprilia, BMW, Maico & more 1 31-03-2010 09:04 PM
Bike Electrical Theory beatle_bayly Tech Talk 17 31-03-2008 03:52 PM
XR250R electrical problem peanuts Honda Forum 1 08-02-2008 10:15 AM


All times are GMT +11. The time now is 07:20 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.